This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-07-15 13:30
Elapsed7m7s
Revision
Buildergke-prow-ssd-pool-1a225945-n47b
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/62180e57-9bdb-40cd-87db-a0251d85e4b6/targets/test'}}
podac438b49-a704-11e9-8217-96c43017ab5b
resultstorehttps://source.cloud.google.com/results/invocations/62180e57-9bdb-40cd-87db-a0251d85e4b6/targets/test
infra-commitbd463a24f
job-versionv1.13.9-beta.0.1+e1be42a61576dc
podac438b49-a704-11e9-8217-96c43017ab5b
revisionv1.13.9-beta.0.1+e1be42a61576dc

Test Failures


Up 1m35s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-1cf144fac9 --image-family=cos-lts-2 --image-project=gke-node-images-test --cluster-version=1.13.9-beta.0.1+e1be42a61576dc test-1cf144fac9: exit status 1
				from junit_runner.xml

Filter through log files


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 12 lines ...
I0715 13:30:59.575] process 44 exited with code 0 after 0.0m
I0715 13:30:59.575] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0715 13:30:59.576] Root: /workspace
I0715 13:30:59.576] cd to /workspace
I0715 13:30:59.576] Configure environment...
I0715 13:30:59.576] Call:  git show -s --format=format:%ct HEAD
W0715 13:30:59.580] fatal: Not a git repository (or any of the parent directories): .git
I0715 13:30:59.580] process 56 exited with code 128 after 0.0m
W0715 13:30:59.581] Unable to print commit date for HEAD
I0715 13:30:59.581] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0715 13:31:00.115] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0715 13:31:00.460] process 57 exited with code 0 after 0.0m
I0715 13:31:00.461] Call:  gcloud config get-value account
... skipping 415 lines ...
W0715 13:34:10.027] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0715 13:34:10.028] WARNING: The Pod address range limits the maximum size of the cluster. Please refer to https://cloud.google.com/kubernetes-engine/docs/how-to/flexible-pod-cidr to learn how to optimize IP address allocation.
W0715 13:34:10.029] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0715 13:34:10.029] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0715 13:34:13.777] Creating cluster test-1cf144fac9 in us-west1-b...
W0715 13:34:54.833] ............................................................................................................................................................................................................done.
W0715 13:34:54.934] ERROR: (gcloud.container.clusters.create) Operation [<Operation
W0715 13:34:54.934]  clusterConditions: []
W0715 13:34:54.935]  detail: u'Failed to create cluster'
W0715 13:34:54.935]  endTime: u'2019-07-15T13:34:51.043514323Z'
W0715 13:34:54.935]  name: u'operation-1563197653715-dcdce8b0'
W0715 13:34:54.935]  nodepoolConditions: []
W0715 13:34:54.935]  operationType: OperationTypeValueValuesEnum(CREATE_CLUSTER, 1)
W0715 13:34:54.936]  selfLink: u'https://test-container.sandbox.googleapis.com/v1/projects/297184465598/zones/us-west1-b/operations/operation-1563197653715-dcdce8b0'
W0715 13:34:54.936]  startTime: u'2019-07-15T13:34:13.715801821Z'
W0715 13:34:54.936]  status: StatusValueValuesEnum(DONE, 3)
W0715 13:34:54.936]  statusMessage: u'Failed to create cluster'
W0715 13:34:54.936]  targetLink: u'https://test-container.sandbox.googleapis.com/v1/projects/297184465598/zones/us-west1-b/clusters/test-1cf144fac9'
W0715 13:34:54.936]  zone: u'us-west1-b'>] finished with error: Failed to create cluster
W0715 13:34:55.020] 2019/07/15 13:34:55 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-1cf144fac9 --image-family=cos-lts-2 --image-project=gke-node-images-test --cluster-version=1.13.9-beta.0.1+e1be42a61576dc test-1cf144fac9' finished in 45.528029421s
W0715 13:34:55.831] 2019/07/15 13:34:55 process.go:153: Running: bash -c 
W0715 13:34:55.831] function log_dump_custom_get_instances() {
W0715 13:34:55.832]   if [[ $1 == "master" ]]; then
W0715 13:34:55.832]     return 0
W0715 13:34:55.832]   fi
... skipping 39 lines ...
W0715 13:36:36.954] 2019/07/15 13:36:36 process.go:155: Step 'gcloud compute firewall-rules describe e2e-ports-a890be9a --project=k8s-jkns-e2e-gce-plugin-gpus --format=value(name)' finished in 993.503102ms
W0715 13:36:36.955] 2019/07/15 13:36:36 gke.go:621: Found no rules for firewall 'e2e-ports-a890be9a', assuming resources are clean
W0715 13:36:37.929] 2019/07/15 13:36:37 process.go:153: Running: gcloud compute networks delete -q test-1cf144fac9 --project=k8s-jkns-e2e-gce-plugin-gpus
W0715 13:37:52.491] Deleted [https://www.googleapis.com/compute/v1/projects/k8s-jkns-e2e-gce-plugin-gpus/global/networks/test-1cf144fac9].
W0715 13:37:52.609] 2019/07/15 13:37:52 process.go:155: Step 'gcloud compute networks delete -q test-1cf144fac9 --project=k8s-jkns-e2e-gce-plugin-gpus' finished in 1m14.679182669s
W0715 13:37:52.610] 2019/07/15 13:37:52 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0715 13:37:54.134] 2019/07/15 13:37:54 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-1cf144fac9 --image-family=cos-lts-2 --image-project=gke-node-images-test --cluster-version=1.13.9-beta.0.1+e1be42a61576dc test-1cf144fac9: exit status 1
W0715 13:37:54.135] Traceback (most recent call last):
W0715 13:37:54.136]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0715 13:37:54.136]     main(parse_args())
W0715 13:37:54.136]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0715 13:37:54.136]     mode.start(runner_args)
W0715 13:37:54.136]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0715 13:37:54.137]     check_env(env, self.command, *args)
W0715 13:37:54.137]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0715 13:37:54.137]     subprocess.check_call(cmd, env=env)
W0715 13:37:54.137]   File "/usr/lib/python2.7/subprocess.py", line 186, in check_call
W0715 13:37:54.137]     raise CalledProcessError(retcode, cmd)
W0715 13:37:54.138] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-1cf144fac9', '--gcp-network=test-1cf144fac9', '--check-leaked-resources', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=cos-lts-2', '--image-project=gke-node-images-test', '--gcp-node-image=custom', '--extract=ci/k8s-stable2', '--gcp-project-type=gpu-project', '--timeout=180m', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gcp-zone=us-west1-b')' returned non-zero exit status 1
E0715 13:37:54.146] Command failed
I0715 13:37:54.146] process 259 exited with code 1 after 6.9m
E0715 13:37:54.146] FAIL: ci-kubernetes-e2e-gke-cos2-k8sstable2-gpu
I0715 13:37:54.146] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0715 13:37:54.868] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0715 13:37:54.928] process 1368 exited with code 0 after 0.0m
I0715 13:37:54.928] Call:  gcloud config get-value account
I0715 13:37:55.390] process 1380 exited with code 0 after 0.0m
I0715 13:37:55.390] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0715 13:37:55.391] Upload result and artifacts...
I0715 13:37:55.391] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-cos2-k8sstable2-gpu/1150759592557285377
I0715 13:37:55.391] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-cos2-k8sstable2-gpu/1150759592557285377/artifacts
W0715 13:37:56.860] CommandException: One or more URLs matched no objects.
E0715 13:37:57.041] Command failed
I0715 13:37:57.041] process 1392 exited with code 1 after 0.0m
W0715 13:37:57.042] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-cos2-k8sstable2-gpu/1150759592557285377/artifacts not exist yet
I0715 13:37:57.042] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-cos2-k8sstable2-gpu/1150759592557285377/artifacts
I0715 13:37:59.745] process 1534 exited with code 0 after 0.0m
I0715 13:37:59.746] Call:  git rev-parse HEAD
W0715 13:37:59.753] fatal: Not a git repository (or any of the parent directories): .git
E0715 13:37:59.754] Command failed
I0715 13:37:59.754] process 2058 exited with code 128 after 0.0m
I0715 13:37:59.754] Call:  git rev-parse HEAD
I0715 13:37:59.760] process 2059 exited with code 0 after 0.0m
I0715 13:37:59.761] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-cos2-k8sstable2-gpu/jobResultsCache.json
I0715 13:38:01.556] process 2060 exited with code 0 after 0.0m
I0715 13:38:01.559] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-cos2-k8sstable2-gpu/jobResultsCache.json#1563183562293942'
... skipping 8 lines ...