This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-02-17 23:08
Elapsed3m28s
Revision
Buildergke-prow-default-pool-cf4891d4-6stf
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/36b52819-8610-4c75-9d00-bd64c6981431/targets/test'}}
pod4fe508ec-51da-11ea-9bea-16a0f55e352c
resultstorehttps://source.cloud.google.com/results/invocations/36b52819-8610-4c75-9d00-bd64c6981431/targets/test
infra-commit92e4176fa
job-versionv1.17.4-beta.0.1+aa9a28326e8075
pod4fe508ec-51da-11ea-9bea-16a0f55e352c
revisionv1.17.4-beta.0.1+aa9a28326e8075

Test Failures


Up 45s

error creating cluster: error during gcloud container clusters create --quiet --project=k8s-jkns-gke-slow-1-3 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=test-b726bad088 --cluster-version=1.17.4-beta.0.1+aa9a28326e8075 test-b726bad088: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0217 23:08:52.538] process 47 exited with code 0 after 0.0m
I0217 23:08:52.538] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0217 23:08:52.539] Root: /workspace
I0217 23:08:52.539] cd to /workspace
I0217 23:08:52.539] Configure environment...
I0217 23:08:52.539] Call:  git show -s --format=format:%ct HEAD
W0217 23:08:52.544] fatal: not a git repository (or any of the parent directories): .git
I0217 23:08:52.544] process 60 exited with code 128 after 0.0m
W0217 23:08:52.544] Unable to print commit date for HEAD
I0217 23:08:52.545] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0217 23:08:53.240] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0217 23:08:53.601] process 61 exited with code 0 after 0.0m
I0217 23:08:53.602] Call:  gcloud config get-value account
... skipping 432 lines ...
W0217 23:12:03.464] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0217 23:12:03.464] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0217 23:12:03.464] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0217 23:12:03.465] WARNING: Starting with version 1.18, clusters will have shielded GKE nodes by default.
W0217 23:12:03.465] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0217 23:12:03.465] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0217 23:12:03.560] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0217 23:12:03.632] 2020/02/17 23:12:03 process.go:155: Step 'gcloud container clusters create --quiet --project=k8s-jkns-gke-slow-1-3 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=test-b726bad088 --cluster-version=1.17.4-beta.0.1+aa9a28326e8075 test-b726bad088' finished in 975.915578ms
W0217 23:12:05.607] 2020/02/17 23:12:05 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0217 23:12:05.616] 2020/02/17 23:12:05 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --quiet --project=k8s-jkns-gke-slow-1-3 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=test-b726bad088 --cluster-version=1.17.4-beta.0.1+aa9a28326e8075 test-b726bad088: exit status 1
W0217 23:12:05.622] Traceback (most recent call last):
W0217 23:12:05.622]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0217 23:12:05.623]     main(parse_args())
W0217 23:12:05.623]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0217 23:12:05.623]     mode.start(runner_args)
W0217 23:12:05.623]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0217 23:12:05.625]     check_env(env, self.command, *args)
W0217 23:12:05.625]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0217 23:12:05.625]     subprocess.check_call(cmd, env=env)
W0217 23:12:05.625]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0217 23:12:05.626]     raise CalledProcessError(retcode, cmd)
W0217 23:12:05.627] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-b726bad088', '--gcp-network=test-b726bad088', '--check-leaked-resources', '--gcp-zone=us-west1-c', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--gcp-node-image=gci', '--extract=ci/latest-1.17', '--timeout=150m', '--test_args=--ginkgo.focus=\\[Slow\\] --ginkgo.skip=\\[Serial\\]|\\[Disruptive\\]|\\[Flaky\\]|\\[Feature:.+\\] --minStartupPods=8', '--ginkgo-parallel=30')' returned non-zero exit status 1
E0217 23:12:05.651] Command failed
I0217 23:12:05.651] process 268 exited with code 1 after 3.2m
E0217 23:12:05.652] FAIL: ci-kubernetes-e2e-gke-cos-k8sbeta-slow
I0217 23:12:05.652] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0217 23:12:06.434] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0217 23:12:06.529] process 1400 exited with code 0 after 0.0m
I0217 23:12:06.530] Call:  gcloud config get-value account
I0217 23:12:07.254] process 1413 exited with code 0 after 0.0m
I0217 23:12:07.255] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0217 23:12:07.255] Upload result and artifacts...
I0217 23:12:07.255] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-cos-k8sbeta-slow/1229543160149970947
I0217 23:12:07.255] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-cos-k8sbeta-slow/1229543160149970947/artifacts
W0217 23:12:09.068] CommandException: One or more URLs matched no objects.
E0217 23:12:09.295] Command failed
I0217 23:12:09.296] process 1426 exited with code 1 after 0.0m
W0217 23:12:09.296] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-cos-k8sbeta-slow/1229543160149970947/artifacts not exist yet
I0217 23:12:09.296] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-cos-k8sbeta-slow/1229543160149970947/artifacts
I0217 23:12:12.248] process 1571 exited with code 0 after 0.0m
I0217 23:12:12.248] Call:  git rev-parse HEAD
W0217 23:12:12.260] fatal: not a git repository (or any of the parent directories): .git
E0217 23:12:12.260] Command failed
I0217 23:12:12.260] process 2098 exited with code 128 after 0.0m
I0217 23:12:12.261] Call:  git rev-parse HEAD
I0217 23:12:12.275] process 2099 exited with code 0 after 0.0m
I0217 23:12:12.276] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-cos-k8sbeta-slow/jobResultsCache.json
I0217 23:12:14.381] process 2100 exited with code 0 after 0.0m
I0217 23:12:14.382] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-cos-k8sbeta-slow/jobResultsCache.json#1581977551375041'
... skipping 8 lines ...