This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 5 succeeded
Started2020-03-14 02:20
Elapsed51m51s
Revision
Builder3157b7e6-659a-11ea-8023-9a87cb763276
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/934f78cf-2cde-4c84-9a8b-3b9408b24221/targets/test'}}
resultstorehttps://source.cloud.google.com/results/invocations/934f78cf-2cde-4c84-9a8b-3b9408b24221/targets/test
infra-commit12f848798
job-versionv1.17.5-beta.0.1+106c255ad7ab80
repok8s.io/kubernetes
repo-commit106c255ad7ab80e44ae87fb9745cd479ba787919
repos{u'k8s.io/kubernetes': u'release-1.17'}
revisionv1.17.5-beta.0.1+106c255ad7ab80

Test Failures


Up 28m51s

error creating cluster: cannot deploy: cannot get the create deployment future response: Code="DeploymentFailed" Message="At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/DeployOperations for usage details." Details=[{"code":"Conflict","message":"{\r\n  \"status\": \"Failed\",\r\n  \"error\": {\r\n    \"code\": \"ResourceDeploymentFailure\",\r\n    \"message\": \"The resource operation completed with terminal provisioning state 'Failed'.\",\r\n    \"details\": [\r\n      {\r\n        \"code\": \"VMExtensionProvisioningError\",\r\n        \"message\": \"VM has reported a failure when processing extension 'cse-agent-0'. Error message: \\\"Command execution finished, but failed because it returned a non-zero exit code of: '1'. The command had an error output of: ''\\\"\\r\\n\\r\\nMore information on troubleshooting is available at https://aka.ms/VMExtensionCSEWindowsTroubleshoot \"\r\n      }\r\n    ]\r\n  }\r\n}"},{"code":"Conflict","message":"{\r\n  \"status\": \"Failed\",\r\n  \"error\": {\r\n    \"code\": \"ResourceDeploymentFailure\",\r\n    \"message\": \"The resource operation completed with terminal provisioning state 'Failed'.\",\r\n    \"details\": [\r\n      {\r\n        \"code\": \"VMExtensionProvisioningError\",\r\n        \"message\": \"VM has reported a failure when processing extension 'cse-agent-1'. Error message: \\\"Command execution finished, but failed because it returned a non-zero exit code of: '1'. The command had an error output of: ''\\\"\\r\\n\\r\\nMore information on troubleshooting is available at https://aka.ms/VMExtensionCSEWindowsTroubleshoot \"\r\n      }\r\n    ]\r\n  }\r\n}"}]
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 5 Passed Tests

Error lines from build-log.txt

... skipping 218 lines ...
W0314 02:58:05.635] 2020/03/14 02:58:05 process.go:155: Step 'bash -c /workspace/aks611020687/win-ci-logs-collector.sh kubetest-87ccdd45-659a-11ea-b24e-660694fbbf70.westeurope.cloudapp.azure.com /workspace/aks611020687 /workspace/.ssh/id_rsa' finished in 7.982524ms
W0314 02:58:05.636] 2020/03/14 02:58:05 azure.go:1174: Deleting resource group: kubetest-87ccdd45-659a-11ea-b24e-660694fbbf70.
I0314 02:58:05.736] ssh key file /workspace/.ssh/id_rsa does not exist. Exiting.
W0314 03:11:52.280] 2020/03/14 03:11:52 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0314 03:11:52.281] 2020/03/14 03:11:52 process.go:153: Running: bash -c . hack/lib/version.sh && KUBE_ROOT=. kube::version::get_version_vars && echo "${KUBE_GIT_VERSION-}"
W0314 03:11:53.694] 2020/03/14 03:11:53 process.go:155: Step 'bash -c . hack/lib/version.sh && KUBE_ROOT=. kube::version::get_version_vars && echo "${KUBE_GIT_VERSION-}"' finished in 1.414044324s
W0314 03:11:53.696] 2020/03/14 03:11:53 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: cannot deploy: cannot get the create deployment future response: Code="DeploymentFailed" Message="At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/DeployOperations for usage details." Details=[{"code":"Conflict","message":"{\r\n  \"status\": \"Failed\",\r\n  \"error\": {\r\n    \"code\": \"ResourceDeploymentFailure\",\r\n    \"message\": \"The resource operation completed with terminal provisioning state 'Failed'.\",\r\n    \"details\": [\r\n      {\r\n        \"code\": \"VMExtensionProvisioningError\",\r\n        \"message\": \"VM has reported a failure when processing extension 'cse-agent-0'. Error message: \\\"Command execution finished, but failed because it returned a non-zero exit code of: '1'. The command had an error output of: ''\\\"\\r\\n\\r\\nMore information on troubleshooting is available at https://aka.ms/VMExtensionCSEWindowsTroubleshoot \"\r\n      }\r\n    ]\r\n  }\r\n}"},{"code":"Conflict","message":"{\r\n  \"status\": \"Failed\",\r\n  \"error\": {\r\n    \"code\": \"ResourceDeploymentFailure\",\r\n    \"message\": \"The resource operation completed with terminal provisioning state 'Failed'.\",\r\n    \"details\": [\r\n      {\r\n        \"code\": \"VMExtensionProvisioningError\",\r\n        \"message\": \"VM has reported a failure when processing extension 'cse-agent-1'. Error message: \\\"Command execution finished, but failed because it returned a non-zero exit code of: '1'. The command had an error output of: ''\\\"\\r\\n\\r\\nMore information on troubleshooting is available at https://aka.ms/VMExtensionCSEWindowsTroubleshoot \"\r\n      }\r\n    ]\r\n  }\r\n}"}]
W0314 03:11:53.706] Traceback (most recent call last):
W0314 03:11:53.706]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0314 03:11:53.708]     main(parse_args())
W0314 03:11:53.708]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0314 03:11:53.708]     mode.start(runner_args)
W0314 03:11:53.708]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0314 03:11:53.709]     check_env(env, self.command, *args)
W0314 03:11:53.709]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0314 03:11:53.709]     subprocess.check_call(cmd, env=env)
W0314 03:11:53.709]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0314 03:11:53.710]     raise CalledProcessError(retcode, cmd)
W0314 03:11:53.711] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--build=quick', '--up', '--down', '--test', '--deployment=aksengine', '--provider=skeleton', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--ginkgo-parallel=4', '--aksengine-orchestratorRelease=1.17', '--aksengine-admin-username=azureuser', '--aksengine-admin-password=AdminPassw0rd', '--aksengine-creds=/etc/azure-cred/credentials', '--aksengine-download-url=https://github.com/Azure/aks-engine/releases/download/v0.46.3/aks-engine-v0.46.3-linux-amd64.tar.gz', '--aksengine-public-key=/etc/azure-ssh/azure-ssh-pub', '--aksengine-winZipBuildScript=https://raw.githubusercontent.com/kubernetes-sigs/windows-testing/master/build/build-windows-k8s.sh', '--aksengine-template-url=https://raw.githubusercontent.com/kubernetes-sigs/windows-testing/master/job-templates/kubernetes_release_staging.json', '--aksengine-win-binaries', '--aksengine-deploy-custom-k8s', '--test_args=--num-nodes=3 --node-os-distro=windows --ginkgo.focus=\\[Conformance\\]|\\[NodeConformance\\]|\\[sig-windows\\]|\\[sig-apps\\].CronJob|\\[sig-api-machinery\\].ResourceQuota|\\[sig-scheduling\\].SchedulerPreemption --ginkgo.skip=\\[LinuxOnly\\]|\\[Serial\\]|\\[Slow\\]|Guestbook.application.should.create.and.stop.a.working.application', '--timeout=450m')' returned non-zero exit status 1
E0314 03:11:53.726] Command failed
I0314 03:11:53.726] process 469 exited with code 1 after 50.3m
E0314 03:11:53.727] FAIL: ci-kubernetes-e2e-aks-engine-azure-1-17-windows
I0314 03:11:53.727] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0314 03:11:54.466] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0314 03:11:54.545] process 37640 exited with code 0 after 0.0m
I0314 03:11:54.545] Call:  gcloud config get-value account
I0314 03:11:55.172] process 37654 exited with code 0 after 0.0m
I0314 03:11:55.173] Will upload results to gs://kubernetes-jenkins/logs/ using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0314 03:11:55.173] Upload result and artifacts...
I0314 03:11:55.173] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-aks-engine-azure-1-17-windows/1238651031617802242
I0314 03:11:55.174] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-aks-engine-azure-1-17-windows/1238651031617802242/artifacts
W0314 03:11:56.493] CommandException: One or more URLs matched no objects.
E0314 03:11:56.656] Command failed
I0314 03:11:56.656] process 37668 exited with code 1 after 0.0m
W0314 03:11:56.656] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-aks-engine-azure-1-17-windows/1238651031617802242/artifacts not exist yet
I0314 03:11:56.656] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-aks-engine-azure-1-17-windows/1238651031617802242/artifacts
I0314 03:11:59.252] process 37814 exited with code 0 after 0.0m
I0314 03:11:59.253] Call:  git rev-parse HEAD
I0314 03:11:59.261] process 38366 exited with code 0 after 0.0m
... skipping 13 lines ...