This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 5 succeeded
Started2020-02-15 03:37
Elapsed1h14m
Revision
Buildergke-prow-default-pool-cf4891d4-ndfp
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/8725788f-6628-42e1-bc0a-2e5fb979bc28/targets/test'}}
pod660d4871-4fa4-11ea-9bea-16a0f55e352c
resultstorehttps://source.cloud.google.com/results/invocations/8725788f-6628-42e1-bc0a-2e5fb979bc28/targets/test
infra-commitf5dd3ee0e
job-versionv1.16.8-beta.0.1+abdce0eac9e732-dirty
pod660d4871-4fa4-11ea-9bea-16a0f55e352c
repok8s.io/kubernetes
repo-commitabdce0eac9e732e32c1dac7347c504c7c920c210
repos{u'k8s.io/kubernetes': u'release-1.16'}
revisionv1.16.8-beta.0.1+abdce0eac9e732-dirty

Test Failures


Up 39m13s

error creating cluster: cannot deploy: cannot get the create deployment future response: Code="DeploymentFailed" Message="At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/DeployOperations for usage details." Details=[{"code":"Conflict","message":"{\r\n  \"status\": \"Failed\",\r\n  \"error\": {\r\n    \"code\": \"ResourceDeploymentFailure\",\r\n    \"message\": \"The resource operation completed with terminal provisioning state 'Failed'.\",\r\n    \"details\": [\r\n      {\r\n        \"code\": \"VMExtensionProvisioningError\",\r\n        \"message\": \"VM has reported a failure when processing extension 'cse-agent-0'. Error message: \\\"Command execution finished, but failed because it returned a non-zero exit code of: '1'. The command had an error output of: ''\\\"\\r\\n\\r\\nMore information on troubleshooting is available at https://aka.ms/VMExtensionCSEWindowsTroubleshoot \"\r\n      }\r\n    ]\r\n  }\r\n}"}]
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 5 Passed Tests

Error lines from build-log.txt

... skipping 328 lines ...
I0215 04:38:14.670] Get Windows nodes.
I0215 04:38:14.670] Agent pid 108971
I0215 04:38:14.671] Unable to add SSH_KEY to ssh-agent. Exiting.
W0215 04:52:19.787] 2020/02/15 04:52:19 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0215 04:52:19.788] 2020/02/15 04:52:19 process.go:153: Running: bash -c . hack/lib/version.sh && KUBE_ROOT=. kube::version::get_version_vars && echo "${KUBE_GIT_VERSION-}"
W0215 04:52:21.601] 2020/02/15 04:52:21 process.go:155: Step 'bash -c . hack/lib/version.sh && KUBE_ROOT=. kube::version::get_version_vars && echo "${KUBE_GIT_VERSION-}"' finished in 1.814363325s
W0215 04:52:21.603] 2020/02/15 04:52:21 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: cannot deploy: cannot get the create deployment future response: Code="DeploymentFailed" Message="At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/DeployOperations for usage details." Details=[{"code":"Conflict","message":"{\r\n  \"status\": \"Failed\",\r\n  \"error\": {\r\n    \"code\": \"ResourceDeploymentFailure\",\r\n    \"message\": \"The resource operation completed with terminal provisioning state 'Failed'.\",\r\n    \"details\": [\r\n      {\r\n        \"code\": \"VMExtensionProvisioningError\",\r\n        \"message\": \"VM has reported a failure when processing extension 'cse-agent-0'. Error message: \\\"Command execution finished, but failed because it returned a non-zero exit code of: '1'. The command had an error output of: ''\\\"\\r\\n\\r\\nMore information on troubleshooting is available at https://aka.ms/VMExtensionCSEWindowsTroubleshoot \"\r\n      }\r\n    ]\r\n  }\r\n}"}]
W0215 04:52:21.612] Traceback (most recent call last):
W0215 04:52:21.612]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0215 04:52:21.614]     main(parse_args())
W0215 04:52:21.614]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0215 04:52:21.614]     mode.start(runner_args)
W0215 04:52:21.615]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0215 04:52:21.615]     check_env(env, self.command, *args)
W0215 04:52:21.615]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0215 04:52:21.615]     subprocess.check_call(cmd, env=env)
W0215 04:52:21.615]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0215 04:52:21.615]     raise CalledProcessError(retcode, cmd)
W0215 04:52:21.617] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--build=quick', '--up', '--down', '--test', '--deployment=aksengine', '--provider=skeleton', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--aksengine-admin-username=azureuser', '--aksengine-admin-password=AdminPassw0rd', '--aksengine-creds=/etc/azure-cred/credentials', '--aksengine-download-url=https://github.com/Azure/aks-engine/releases/download/v0.46.3/aks-engine-v0.46.3-linux-amd64.tar.gz', '--aksengine-public-key=/etc/azure-ssh/azure-ssh-pub', '--aksengine-winZipBuildScript=https://raw.githubusercontent.com/kubernetes-sigs/windows-testing/master/build/build-windows-k8s.sh', '--aksengine-orchestratorRelease=1.16', '--aksengine-template-url=https://raw.githubusercontent.com/kubernetes-sigs/windows-testing/master/job-templates/kubernetes_release_1_16.json', '--aksengine-win-binaries', '--aksengine-deploy-custom-k8s', '--aksengine-agentpoolcount=2', '--test_args=--num-nodes=2 --node-os-distro=windows --ginkgo.focus=\\[Conformance\\]|\\[NodeConformance\\]|\\[sig-windows\\]|\\[sig-apps\\].CronJob|\\[sig-api-machinery\\].ResourceQuota|\\[sig-scheduling\\].SchedulerPreemption|\\[sig-autoscaling\\].\\[Feature:HPA\\]  --ginkgo.skip=\\[LinuxOnly\\]|GMSA|Guestbook.application.should.create.and.stop.a.working.application', '--timeout=620m')' returned non-zero exit status 1
E0215 04:52:21.632] Command failed
I0215 04:52:21.633] process 464 exited with code 1 after 73.1m
E0215 04:52:21.633] FAIL: ci-kubernetes-e2e-aks-engine-azure-1-16-windows
I0215 04:52:21.633] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0215 04:52:22.980] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0215 04:52:23.054] process 109006 exited with code 0 after 0.0m
I0215 04:52:23.055] Call:  gcloud config get-value account
I0215 04:52:23.623] process 109019 exited with code 0 after 0.0m
I0215 04:52:23.623] Will upload results to gs://kubernetes-jenkins/logs/ using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0215 04:52:23.624] Upload result and artifacts...
I0215 04:52:23.624] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-aks-engine-azure-1-16-windows/1228523691390799874
I0215 04:52:23.624] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-aks-engine-azure-1-16-windows/1228523691390799874/artifacts
W0215 04:52:25.566] CommandException: One or more URLs matched no objects.
E0215 04:52:25.735] Command failed
I0215 04:52:25.735] process 109032 exited with code 1 after 0.0m
W0215 04:52:25.735] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-aks-engine-azure-1-16-windows/1228523691390799874/artifacts not exist yet
I0215 04:52:25.736] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-aks-engine-azure-1-16-windows/1228523691390799874/artifacts
I0215 04:52:28.270] process 109177 exited with code 0 after 0.0m
I0215 04:52:28.271] Call:  git rev-parse HEAD
I0215 04:52:28.278] process 109728 exited with code 0 after 0.0m
... skipping 13 lines ...