This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 5 succeeded
Started2020-02-09 03:26
Elapsed1h14m
Revision
Buildergke-prow-default-pool-cf4891d4-z1x5
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/3bcf00d6-b990-4a1d-8b3c-38de67ba30d1/targets/test'}}
pode7a50039-4aeb-11ea-9d03-564fe64f5f51
resultstorehttps://source.cloud.google.com/results/invocations/3bcf00d6-b990-4a1d-8b3c-38de67ba30d1/targets/test
infra-commitd58ad2075
job-versionv1.16.7-beta.0.31+b22498712d0cb7-dirty
pode7a50039-4aeb-11ea-9d03-564fe64f5f51
repok8s.io/kubernetes
repo-commitb22498712d0cb77943b837f6fe9695fb9ce02ada
repos{u'k8s.io/kubernetes': u'release-1.16'}
revisionv1.16.7-beta.0.31+b22498712d0cb7-dirty

Test Failures


Up 49m9s

error creating cluster: cannot deploy: cannot get the create deployment future response: Code="DeploymentFailed" Message="At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/DeployOperations for usage details." Details=[{"code":"Conflict","message":"{\r\n  \"status\": \"Failed\",\r\n  \"error\": {\r\n    \"code\": \"ResourceDeploymentFailure\",\r\n    \"message\": \"The resource operation completed with terminal provisioning state 'Failed'.\",\r\n    \"details\": [\r\n      {\r\n        \"code\": \"VMExtensionProvisioningError\",\r\n        \"message\": \"VM has reported a failure when processing extension 'cse-agent-1'. Error message: \\\"Command execution finished, but failed because it returned a non-zero exit code of: '1'. The command had an error output of: ''\\\"\\r\\n\\r\\nMore information on troubleshooting is available at https://aka.ms/VMExtensionCSEWindowsTroubleshoot \"\r\n      }\r\n    ]\r\n  }\r\n}"}]
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 5 Passed Tests

Error lines from build-log.txt

... skipping 290 lines ...
I0209 04:32:16.453] daemonset.apps "log-dump-node" deleted
W0209 04:32:16.566] 2020/02/09 04:32:16 process.go:155: Step 'bash -c /workspace/aks210517512/log-dump.sh' finished in 40.219804965s
W0209 04:32:16.566] 2020/02/09 04:32:16 azure.go:1070: Deleting resource group: kubetest-2890d0ad-4aec-11ea-a81d-1e63379070e9.
W0209 04:41:04.484] 2020/02/09 04:41:04 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0209 04:41:04.485] 2020/02/09 04:41:04 process.go:153: Running: bash -c . hack/lib/version.sh && KUBE_ROOT=. kube::version::get_version_vars && echo "${KUBE_GIT_VERSION-}"
W0209 04:41:04.705] 2020/02/09 04:41:04 process.go:155: Step 'bash -c . hack/lib/version.sh && KUBE_ROOT=. kube::version::get_version_vars && echo "${KUBE_GIT_VERSION-}"' finished in 220.539738ms
W0209 04:41:04.710] 2020/02/09 04:41:04 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: cannot deploy: cannot get the create deployment future response: Code="DeploymentFailed" Message="At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/DeployOperations for usage details." Details=[{"code":"Conflict","message":"{\r\n  \"status\": \"Failed\",\r\n  \"error\": {\r\n    \"code\": \"ResourceDeploymentFailure\",\r\n    \"message\": \"The resource operation completed with terminal provisioning state 'Failed'.\",\r\n    \"details\": [\r\n      {\r\n        \"code\": \"VMExtensionProvisioningError\",\r\n        \"message\": \"VM has reported a failure when processing extension 'cse-agent-1'. Error message: \\\"Command execution finished, but failed because it returned a non-zero exit code of: '1'. The command had an error output of: ''\\\"\\r\\n\\r\\nMore information on troubleshooting is available at https://aka.ms/VMExtensionCSEWindowsTroubleshoot \"\r\n      }\r\n    ]\r\n  }\r\n}"}]
W0209 04:41:04.714] Traceback (most recent call last):
W0209 04:41:04.714]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0209 04:41:04.717]     main(parse_args())
W0209 04:41:04.718]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0209 04:41:04.718]     mode.start(runner_args)
W0209 04:41:04.718]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0209 04:41:04.718]     check_env(env, self.command, *args)
W0209 04:41:04.718]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0209 04:41:04.718]     subprocess.check_call(cmd, env=env)
W0209 04:41:04.719]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0209 04:41:04.720]     raise CalledProcessError(retcode, cmd)
W0209 04:41:04.721] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--build=quick', '--up', '--down', '--test', '--deployment=aksengine', '--provider=skeleton', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--aksengine-admin-username=azureuser', '--aksengine-admin-password=AdminPassw0rd', '--aksengine-creds=/etc/azure-cred/credentials', '--aksengine-download-url=https://github.com/Azure/aks-engine/releases/download/v0.46.3/aks-engine-v0.46.3-linux-amd64.tar.gz', '--aksengine-public-key=/etc/azure-ssh/azure-ssh-pub', '--aksengine-winZipBuildScript=https://raw.githubusercontent.com/kubernetes-sigs/windows-testing/master/build/build-windows-k8s.sh', '--aksengine-orchestratorRelease=1.16', '--aksengine-template-url=https://raw.githubusercontent.com/kubernetes-sigs/windows-testing/master/job-templates/kubernetes_release_1_16.json', '--aksengine-win-binaries', '--aksengine-deploy-custom-k8s', '--aksengine-agentpoolcount=2', '--test_args=--num-nodes=2 --node-os-distro=windows --ginkgo.focus=\\[Conformance\\]|\\[NodeConformance\\]|\\[sig-windows\\]|\\[sig-apps\\].CronJob|\\[sig-api-machinery\\].ResourceQuota|\\[sig-scheduling\\].SchedulerPreemption|\\[sig-autoscaling\\].\\[Feature:HPA\\]  --ginkgo.skip=\\[LinuxOnly\\]|GMSA|Guestbook.application.should.create.and.stop.a.working.application', '--timeout=620m')' returned non-zero exit status 1
E0209 04:41:04.731] Command failed
I0209 04:41:04.731] process 497 exited with code 1 after 73.2m
E0209 04:41:04.731] FAIL: ci-kubernetes-e2e-aks-engine-azure-1-16-windows
I0209 04:41:04.732] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0209 04:41:05.202] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0209 04:41:05.251] process 108344 exited with code 0 after 0.0m
I0209 04:41:05.251] Call:  gcloud config get-value account
I0209 04:41:05.604] process 108357 exited with code 0 after 0.0m
I0209 04:41:05.604] Will upload results to gs://kubernetes-jenkins/logs/ using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0209 04:41:05.604] Upload result and artifacts...
I0209 04:41:05.604] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-aks-engine-azure-1-16-windows/1226346629393551363
I0209 04:41:05.605] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-aks-engine-azure-1-16-windows/1226346629393551363/artifacts
W0209 04:41:06.523] CommandException: One or more URLs matched no objects.
E0209 04:41:06.623] Command failed
I0209 04:41:06.623] process 108370 exited with code 1 after 0.0m
W0209 04:41:06.623] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-aks-engine-azure-1-16-windows/1226346629393551363/artifacts not exist yet
I0209 04:41:06.623] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-aks-engine-azure-1-16-windows/1226346629393551363/artifacts
I0209 04:41:08.368] process 108515 exited with code 0 after 0.0m
I0209 04:41:08.368] Call:  git rev-parse HEAD
I0209 04:41:08.372] process 109066 exited with code 0 after 0.0m
... skipping 13 lines ...