This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 5 succeeded
Started2020-02-08 13:40
Elapsed1h11m
Revision
Buildergke-prow-default-pool-cf4891d4-p8rj
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/64812a43-0412-485c-8356-fabe08c045e9/targets/test'}}
pod83ade7a8-4a78-11ea-9d03-564fe64f5f51
resultstorehttps://source.cloud.google.com/results/invocations/64812a43-0412-485c-8356-fabe08c045e9/targets/test
infra-commit18391d898
job-versionv1.15.10-beta.0.17+2e0c2c47211680-dirty
pod83ade7a8-4a78-11ea-9d03-564fe64f5f51
repok8s.io/kubernetes
repo-commit2e0c2c4721168078d2d5ff07018467d005f30f5a
repos{u'k8s.io/kubernetes': u'release-1.15'}
revisionv1.15.10-beta.0.17+2e0c2c47211680-dirty

Test Failures


Up 46m31s

error creating cluster: cannot deploy: cannot get the create deployment future response: Code="DeploymentFailed" Message="At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/DeployOperations for usage details." Details=[{"code":"Conflict","message":"{\r\n  \"status\": \"Failed\",\r\n  \"error\": {\r\n    \"code\": \"ResourceDeploymentFailure\",\r\n    \"message\": \"The resource operation completed with terminal provisioning state 'Failed'.\",\r\n    \"details\": [\r\n      {\r\n        \"code\": \"VMExtensionProvisioningError\",\r\n        \"message\": \"VM has reported a failure when processing extension 'cse-agent-0'. Error message: \\\"Command execution finished, but failed because it returned a non-zero exit code of: '1'. The command had an error output of: ''\\\"\\r\\n\\r\\nMore information on troubleshooting is available at https://aka.ms/VMExtensionCSEWindowsTroubleshoot \"\r\n      }\r\n    ]\r\n  }\r\n}"}]
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 5 Passed Tests

Error lines from build-log.txt

... skipping 292 lines ...
I0208 14:44:34.193] daemonset.apps "log-dump-node" deleted
W0208 14:44:34.309] 2020/02/08 14:44:34 process.go:155: Step 'bash -c /workspace/aks110214094/log-dump.sh' finished in 42.241648643s
W0208 14:44:34.310] 2020/02/08 14:44:34 azure.go:1070: Deleting resource group: kubetest-c2dbff3a-4a78-11ea-bdb2-568b2f4d2829.
W0208 14:52:13.179] 2020/02/08 14:52:13 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0208 14:52:13.179] 2020/02/08 14:52:13 process.go:153: Running: bash -c . hack/lib/version.sh && KUBE_ROOT=. kube::version::get_version_vars && echo "${KUBE_GIT_VERSION-}"
W0208 14:52:13.411] 2020/02/08 14:52:13 process.go:155: Step 'bash -c . hack/lib/version.sh && KUBE_ROOT=. kube::version::get_version_vars && echo "${KUBE_GIT_VERSION-}"' finished in 231.550329ms
W0208 14:52:13.412] 2020/02/08 14:52:13 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: cannot deploy: cannot get the create deployment future response: Code="DeploymentFailed" Message="At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/DeployOperations for usage details." Details=[{"code":"Conflict","message":"{\r\n  \"status\": \"Failed\",\r\n  \"error\": {\r\n    \"code\": \"ResourceDeploymentFailure\",\r\n    \"message\": \"The resource operation completed with terminal provisioning state 'Failed'.\",\r\n    \"details\": [\r\n      {\r\n        \"code\": \"VMExtensionProvisioningError\",\r\n        \"message\": \"VM has reported a failure when processing extension 'cse-agent-0'. Error message: \\\"Command execution finished, but failed because it returned a non-zero exit code of: '1'. The command had an error output of: ''\\\"\\r\\n\\r\\nMore information on troubleshooting is available at https://aka.ms/VMExtensionCSEWindowsTroubleshoot \"\r\n      }\r\n    ]\r\n  }\r\n}"}]
W0208 14:52:13.415] Traceback (most recent call last):
W0208 14:52:13.416]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0208 14:52:13.417]     main(parse_args())
W0208 14:52:13.417]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0208 14:52:13.417]     mode.start(runner_args)
W0208 14:52:13.418]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0208 14:52:13.418]     check_env(env, self.command, *args)
W0208 14:52:13.418]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0208 14:52:13.418]     subprocess.check_call(cmd, env=env)
W0208 14:52:13.418]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0208 14:52:13.418]     raise CalledProcessError(retcode, cmd)
W0208 14:52:13.420] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--build=quick', '--up', '--down', '--test', '--deployment=aksengine', '--provider=skeleton', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--aksengine-admin-username=azureuser', '--aksengine-admin-password=AdminPassw0rd', '--aksengine-creds=/etc/azure-cred/credentials', '--aksengine-download-url=https://github.com/Azure/aks-engine/releases/download/v0.46.3/aks-engine-v0.46.3-linux-amd64.tar.gz', '--aksengine-public-key=/etc/azure-ssh/azure-ssh-pub', '--aksengine-winZipBuildScript=https://raw.githubusercontent.com/kubernetes-sigs/windows-testing/master/build/build-windows-k8s.sh', '--aksengine-orchestratorRelease=1.15', '--aksengine-template-url=https://raw.githubusercontent.com/kubernetes-sigs/windows-testing/master/job-templates/kubernetes_release_1_15.json', '--aksengine-win-binaries', '--aksengine-deploy-custom-k8s', '--aksengine-agentpoolcount=2', '--test_args=--num-nodes=2 --node-os-distro=windows --ginkgo.focus=\\[Conformance\\]|\\[NodeConformance\\]|\\[sig-windows\\]|\\[sig-apps\\].CronJob|\\[sig-api-machinery\\].ResourceQuota|\\[sig-scheduling\\].SchedulerPreemption --ginkgo.skip=\\[LinuxOnly\\]|GMSA', '--timeout=620m')' returned non-zero exit status 1
E0208 14:52:13.431] Command failed
I0208 14:52:13.431] process 494 exited with code 1 after 70.4m
E0208 14:52:13.431] FAIL: ci-kubernetes-e2e-aks-engine-azure-1-15-windows
I0208 14:52:13.432] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0208 14:52:14.731] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0208 14:52:14.806] process 107547 exited with code 0 after 0.0m
I0208 14:52:14.807] Call:  gcloud config get-value account
I0208 14:52:15.393] process 107560 exited with code 0 after 0.0m
I0208 14:52:15.394] Will upload results to gs://kubernetes-jenkins/logs/ using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0208 14:52:15.394] Upload result and artifacts...
I0208 14:52:15.394] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-aks-engine-azure-1-15-windows/1226138748987641857
I0208 14:52:15.395] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-aks-engine-azure-1-15-windows/1226138748987641857/artifacts
W0208 14:52:18.031] CommandException: One or more URLs matched no objects.
E0208 14:52:18.200] Command failed
I0208 14:52:18.201] process 107573 exited with code 1 after 0.0m
W0208 14:52:18.201] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-aks-engine-azure-1-15-windows/1226138748987641857/artifacts not exist yet
I0208 14:52:18.202] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-aks-engine-azure-1-15-windows/1226138748987641857/artifacts
I0208 14:52:21.072] process 107718 exited with code 0 after 0.0m
I0208 14:52:21.073] Call:  git rev-parse HEAD
I0208 14:52:21.079] process 108269 exited with code 0 after 0.0m
... skipping 13 lines ...