This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 0 failed / 0 succeeded
Started2021-09-25 15:10
Elapsed3m17s
Revision
Builderb1425505-1e12-11ec-aa51-d2836bccddff
infra-commit9baaedbc1
reposigs.k8s.io/gcp-compute-persistent-disk-csi-driver
repo-commitf5055fab178a409a53938e4a538984001a3b12e5
repos{u'sigs.k8s.io/gcp-compute-persistent-disk-csi-driver': u'master'}

No Test Failures!


Error lines from build-log.txt

... skipping 55 lines ...
W0925 15:12:10.450] I0925 15:12:10.449867    3628 utils.go:139] Using project kubernetes-gci-es-logging and service account 15829448089-compute@developer.gserviceaccount.com
I0925 15:12:11.376] Pushing GCP Container for Linux
I0925 15:12:11.377] [make -C /go/src/sigs.k8s.io/gcp-compute-persistent-disk-csi-driver push-container GCE_PD_CSI_STAGING_VERSION=61544356-cda0-4737-861a-8d286d1fbcd6 GCE_PD_CSI_STAGING_IMAGE=gcr.io/kubernetes-gci-es-logging/gcp-persistent-disk-csi-driver]
I0925 15:12:11.380] make: Entering directory '/go/src/sigs.k8s.io/gcp-compute-persistent-disk-csi-driver'
I0925 15:12:11.380] # Ensure we use a builder that can leverage it (the default on linux will not)
I0925 15:12:11.381] DOCKER_CLI_EXPERIMENTAL=enabled docker buildx rm multiarch-multiplatform-builder
W0925 15:12:11.611] error: no builder "multiarch-multiplatform-builder" found
W0925 15:12:11.618] make: [Makefile:128: init-buildx] Error 1 (ignored)
I0925 15:12:11.719] DOCKER_CLI_EXPERIMENTAL=enabled docker buildx create --use --name=multiarch-multiplatform-builder
I0925 15:12:11.756] multiarch-multiplatform-builder
I0925 15:12:11.763] DOCKER_CLI_EXPERIMENTAL=enabled docker run --rm --privileged multiarch/qemu-user-static --reset --credential yes --persistent yes
W0925 15:12:11.863] Unable to find image 'multiarch/qemu-user-static:latest' locally
W0925 15:12:12.833] latest: Pulling from multiarch/qemu-user-static
W0925 15:12:12.833] 24fb2886d6f6: Pulling fs layer
... skipping 175 lines ...
W0925 15:13:19.028] #13 3.775 Get:4 http://deb.debian.org/debian buster/main amd64 Packages [7907 kB]
W0925 15:13:19.603] #13 4.351 Get:5 http://deb.debian.org/debian buster-updates/main amd64 Packages [15.2 kB]
W0925 15:13:33.118] #13 ...
W0925 15:13:33.119] 
W0925 15:13:33.119] #14 [mad-hack 2/2] RUN clean-install udev
W0925 15:13:33.119] #14 60.33 Err:3 http://deb.debian.org/debian buster InRelease
W0925 15:13:33.119] #14 60.33   Connection failed [IP: 199.232.98.132 80]
W0925 15:13:33.269] #14 60.41 Get:4 http://deb.debian.org/debian buster-updates InRelease [51.9 kB]
W0925 15:13:33.407] #14 60.62 Get:5 http://deb.debian.org/debian buster-updates/main amd64 Packages [15.2 kB]
W0925 15:13:33.523] #14 60.63 Fetched 437 kB in 60s (7235 B/s)
W0925 15:13:33.524] #14 60.63 Reading package lists...
W0925 15:13:33.524] #14 60.68 W: Failed to fetch http://deb.debian.org/debian/dists/buster/InRelease  Connection failed [IP: 199.232.98.132 80]
W0925 15:13:33.524] #14 60.68 W: Some index files failed to download. They have been ignored, or old ones used instead.
W0925 15:13:33.524] #14 60.69 Reading package lists...
W0925 15:13:33.633] #14 60.74 Building dependency tree...
W0925 15:13:33.633] #14 60.74 Reading state information...
W0925 15:13:33.634] #14 60.75 Some packages could not be installed. This may mean that you have
W0925 15:13:33.634] #14 60.75 requested an impossible situation or if you are using the unstable
W0925 15:13:33.634] #14 60.75 distribution that some required packages have not yet been created
... skipping 3 lines ...
W0925 15:13:33.635] #14 60.75 The following packages have unmet dependencies:
W0925 15:13:33.635] #14 60.75  udev : Depends: libblkid1 (>= 2.24) but it is not installable
W0925 15:13:33.635] #14 60.75         Depends: libkmod2 (>= 5~) but it is not installable
W0925 15:13:33.635] #14 60.75         Depends: lsb-base (>= 3.0-6) but it is not installable
W0925 15:13:33.635] #14 60.75         Depends: util-linux (>= 2.27.1) but it is not installable
W0925 15:13:33.636] #14 60.75 E: Unable to correct problems, you have held broken packages.
W0925 15:13:33.636] #14 ERROR: process "/bin/sh -c clean-install udev" did not complete successfully: exit code: 100
W0925 15:13:33.636] 
W0925 15:13:33.636] #13 [stage-2 3/4] RUN clean-install util-linux e2fsprogs mount ca-certificates udev xfsprogs
W0925 15:13:33.699] #13 CANCELED
W0925 15:13:33.699] ------
W0925 15:13:33.699]  > [mad-hack 2/2] RUN clean-install udev:
W0925 15:13:33.700] #14 60.75 distribution that some required packages have not yet been created
... skipping 12 lines ...
W0925 15:13:33.703]   26 |     # MAD HACKS: Build a version first so we can take the scsi_id bin and put it somewhere else in our real build
W0925 15:13:33.703]   27 |     FROM k8s.gcr.io/build-image/debian-base:buster-v1.9.0 as mad-hack
W0925 15:13:33.703]   28 | >>> RUN clean-install udev
W0925 15:13:33.704]   29 |     
W0925 15:13:33.704]   30 |     # Start from Kubernetes Debian base
W0925 15:13:33.704] --------------------
W0925 15:13:33.704] error: failed to solve: process "/bin/sh -c clean-install udev" did not complete successfully: exit code: 100
W0925 15:13:33.716] make: *** [Makefile:50: build-container] Error 1
I0925 15:13:33.817] make: Leaving directory '/go/src/sigs.k8s.io/gcp-compute-persistent-disk-csi-driver'
W0925 15:13:34.856] F0925 15:13:34.856139    3628 main.go:189] Failed to run integration test: failed pushing image: failed to run make command for linux: err: exit status 2
W0925 15:13:34.860] Traceback (most recent call last):
W0925 15:13:34.861]   File "/workspace/./test-infra/jenkins/../scenarios/execute.py", line 50, in <module>
W0925 15:13:34.861]     main(ARGS.env, ARGS.cmd + ARGS.args)
W0925 15:13:34.861]   File "/workspace/./test-infra/jenkins/../scenarios/execute.py", line 41, in main
W0925 15:13:34.861]     check(*cmd)
W0925 15:13:34.862]   File "/workspace/./test-infra/jenkins/../scenarios/execute.py", line 30, in check
W0925 15:13:34.862]     subprocess.check_call(cmd)
W0925 15:13:34.862]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0925 15:13:34.862]     raise CalledProcessError(retcode, cmd)
W0925 15:13:34.862] subprocess.CalledProcessError: Command '('test/run-k8s-integration-migration.sh',)' returned non-zero exit status 255
E0925 15:13:34.867] Command failed
I0925 15:13:34.867] process 427 exited with code 1 after 3.0m
E0925 15:13:34.867] FAIL: ci-gcp-compute-persistent-disk-csi-driver-latest-k8s-master-migration
I0925 15:13:34.867] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0925 15:13:35.613] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0925 15:13:35.788] process 6540 exited with code 0 after 0.0m
I0925 15:13:35.789] Call:  gcloud config get-value account
I0925 15:13:36.566] process 6553 exited with code 0 after 0.0m
I0925 15:13:36.567] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
... skipping 20 lines ...