This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 0 failed / 0 succeeded
Started2021-09-25 13:08
Elapsed4m45s
Revision
Buildera62a6200-1e01-11ec-aa51-d2836bccddff
infra-commitd5c85c413
reposigs.k8s.io/gcp-compute-persistent-disk-csi-driver
repo-commitf5055fab178a409a53938e4a538984001a3b12e5
repos{u'sigs.k8s.io/gcp-compute-persistent-disk-csi-driver': u'master'}

No Test Failures!


Error lines from build-log.txt

... skipping 55 lines ...
W0925 13:10:10.141] I0925 13:10:10.140582    3625 utils.go:139] Using project k8s-jkns-e2e-gci-gce-alpha and service account 790587036140-compute@developer.gserviceaccount.com
I0925 13:10:10.978] Pushing GCP Container for Linux
I0925 13:10:10.979] [make -C /go/src/sigs.k8s.io/gcp-compute-persistent-disk-csi-driver push-container GCE_PD_CSI_STAGING_VERSION=b670aa76-c5af-429c-9e53-67d48805a953 GCE_PD_CSI_STAGING_IMAGE=gcr.io/k8s-jkns-e2e-gci-gce-alpha/gcp-persistent-disk-csi-driver]
I0925 13:10:10.980] make: Entering directory '/go/src/sigs.k8s.io/gcp-compute-persistent-disk-csi-driver'
I0925 13:10:10.981] # Ensure we use a builder that can leverage it (the default on linux will not)
I0925 13:10:10.982] DOCKER_CLI_EXPERIMENTAL=enabled docker buildx rm multiarch-multiplatform-builder
W0925 13:10:11.109] error: no builder "multiarch-multiplatform-builder" found
W0925 13:10:11.114] make: [Makefile:128: init-buildx] Error 1 (ignored)
I0925 13:10:11.215] DOCKER_CLI_EXPERIMENTAL=enabled docker buildx create --use --name=multiarch-multiplatform-builder
I0925 13:10:11.227] multiarch-multiplatform-builder
I0925 13:10:11.232] DOCKER_CLI_EXPERIMENTAL=enabled docker run --rm --privileged multiarch/qemu-user-static --reset --credential yes --persistent yes
W0925 13:10:11.333] Unable to find image 'multiarch/qemu-user-static:latest' locally
W0925 13:10:12.143] latest: Pulling from multiarch/qemu-user-static
W0925 13:10:12.143] 24fb2886d6f6: Pulling fs layer
... skipping 435 lines ...
W0925 13:11:52.020] #13 45.26 Running hooks in /etc/ca-certificates/update.d...
W0925 13:11:52.020] #13 45.26 done.
W0925 13:11:52.471] #13 DONE 45.6s
W0925 13:11:52.471] 
W0925 13:11:52.471] #14 [mad-hack 2/2] RUN clean-install udev
W0925 13:12:01.199] #14 90.74 Err:1 http://deb.debian.org/debian buster InRelease
W0925 13:12:01.199] #14 90.74   Connection failed [IP: 151.101.186.132 80]
W0925 13:13:01.322] #14 150.8 Err:4 http://deb.debian.org/debian buster-updates InRelease
W0925 13:13:01.323] #14 150.8   Connection failed [IP: 151.101.186.132 80]
W0925 13:13:01.323] #14 150.8 Fetched 370 kB in 2min 30s (2463 B/s)
W0925 13:13:01.323] #14 150.8 Reading package lists...
W0925 13:13:01.323] #14 150.9 W: Failed to fetch http://deb.debian.org/debian/dists/buster/InRelease  Connection failed [IP: 151.101.186.132 80]
W0925 13:13:01.324] #14 150.9 W: Failed to fetch http://deb.debian.org/debian/dists/buster-updates/InRelease  Connection failed [IP: 151.101.186.132 80]
W0925 13:13:01.324] #14 150.9 W: Some index files failed to download. They have been ignored, or old ones used instead.
W0925 13:13:01.324] #14 150.9 Reading package lists...
W0925 13:13:01.386] #14 150.9 Building dependency tree...
W0925 13:13:01.386] #14 150.9 Reading state information...
W0925 13:13:01.386] #14 150.9 Some packages could not be installed. This may mean that you have
W0925 13:13:01.386] #14 150.9 requested an impossible situation or if you are using the unstable
W0925 13:13:01.387] #14 150.9 distribution that some required packages have not yet been created
... skipping 3 lines ...
W0925 13:13:01.388] #14 150.9 The following packages have unmet dependencies:
W0925 13:13:01.388] #14 150.9  udev : Depends: libblkid1 (>= 2.24) but it is not installable
W0925 13:13:01.388] #14 150.9         Depends: libkmod2 (>= 5~) but it is not installable
W0925 13:13:01.388] #14 150.9         Depends: lsb-base (>= 3.0-6) but it is not installable
W0925 13:13:01.388] #14 150.9         Depends: util-linux (>= 2.27.1) but it is not installable
W0925 13:13:01.389] #14 150.9 E: Unable to correct problems, you have held broken packages.
W0925 13:13:01.389] #14 ERROR: process "/bin/sh -c clean-install udev" did not complete successfully: exit code: 100
W0925 13:13:01.389] ------
W0925 13:13:01.389]  > [mad-hack 2/2] RUN clean-install udev:
W0925 13:13:01.390] #14 150.9 distribution that some required packages have not yet been created
W0925 13:13:01.390] #14 150.9 or been moved out of Incoming.
W0925 13:13:01.390] #14 150.9 The following information may help to resolve the situation:
W0925 13:13:01.390] #14 150.9 
... skipping 9 lines ...
W0925 13:13:01.392]   26 |     # MAD HACKS: Build a version first so we can take the scsi_id bin and put it somewhere else in our real build
W0925 13:13:01.392]   27 |     FROM k8s.gcr.io/build-image/debian-base:buster-v1.9.0 as mad-hack
W0925 13:13:01.392]   28 | >>> RUN clean-install udev
W0925 13:13:01.392]   29 |     
W0925 13:13:01.392]   30 |     # Start from Kubernetes Debian base
W0925 13:13:01.392] --------------------
W0925 13:13:01.392] error: failed to solve: process "/bin/sh -c clean-install udev" did not complete successfully: exit code: 100
W0925 13:13:01.398] make: *** [Makefile:50: build-container] Error 1
I0925 13:13:01.499] make: Leaving directory '/go/src/sigs.k8s.io/gcp-compute-persistent-disk-csi-driver'
W0925 13:13:02.316] F0925 13:13:02.316057    3625 main.go:189] Failed to run integration test: failed pushing image: failed to run make command for linux: err: exit status 2
W0925 13:13:02.325] Traceback (most recent call last):
W0925 13:13:02.325]   File "/workspace/./test-infra/jenkins/../scenarios/execute.py", line 50, in <module>
W0925 13:13:02.325]     main(ARGS.env, ARGS.cmd + ARGS.args)
W0925 13:13:02.325]   File "/workspace/./test-infra/jenkins/../scenarios/execute.py", line 41, in main
W0925 13:13:02.325]     check(*cmd)
W0925 13:13:02.325]   File "/workspace/./test-infra/jenkins/../scenarios/execute.py", line 30, in check
W0925 13:13:02.326]     subprocess.check_call(cmd)
W0925 13:13:02.326]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0925 13:13:02.326]     raise CalledProcessError(retcode, cmd)
W0925 13:13:02.326] subprocess.CalledProcessError: Command '('test/run-k8s-integration-migration.sh',)' returned non-zero exit status 255
E0925 13:13:02.326] Command failed
I0925 13:13:02.327] process 429 exited with code 1 after 4.5m
E0925 13:13:02.327] FAIL: ci-gcp-compute-persistent-disk-csi-driver-latest-k8s-master-migration
I0925 13:13:02.327] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0925 13:13:02.999] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0925 13:13:03.151] process 9521 exited with code 0 after 0.0m
I0925 13:13:03.151] Call:  gcloud config get-value account
I0925 13:13:03.807] process 9534 exited with code 0 after 0.0m
I0925 13:13:03.807] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
... skipping 20 lines ...