This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 0 failed / 0 succeeded
Started2021-09-24 21:58
Elapsed3m33s
Revision
Builder92495ea0-1d82-11ec-8616-9ed50c11e500
infra-commit3127df226
reposigs.k8s.io/gcp-compute-persistent-disk-csi-driver
repo-commitf5055fab178a409a53938e4a538984001a3b12e5
repos{u'sigs.k8s.io/gcp-compute-persistent-disk-csi-driver': u'master'}

No Test Failures!


Error lines from build-log.txt

... skipping 55 lines ...
W0924 22:00:34.809] I0924 22:00:34.809093    3631 utils.go:139] Using project k8s-jkns-gce-serial-1-4 and service account 737104602007-compute@developer.gserviceaccount.com
I0924 22:00:35.821] Pushing GCP Container for Linux
I0924 22:00:35.822] [make -C /go/src/sigs.k8s.io/gcp-compute-persistent-disk-csi-driver push-container GCE_PD_CSI_STAGING_VERSION=b270a65f-2964-426e-a0d3-7ebacbaf2df7 GCE_PD_CSI_STAGING_IMAGE=gcr.io/k8s-jkns-gce-serial-1-4/gcp-persistent-disk-csi-driver]
I0924 22:00:35.824] make: Entering directory '/go/src/sigs.k8s.io/gcp-compute-persistent-disk-csi-driver'
I0924 22:00:35.824] # Ensure we use a builder that can leverage it (the default on linux will not)
I0924 22:00:35.825] DOCKER_CLI_EXPERIMENTAL=enabled docker buildx rm multiarch-multiplatform-builder
W0924 22:00:36.236] error: no builder "multiarch-multiplatform-builder" found
W0924 22:00:36.244] make: [Makefile:128: init-buildx] Error 1 (ignored)
I0924 22:00:36.345] DOCKER_CLI_EXPERIMENTAL=enabled docker buildx create --use --name=multiarch-multiplatform-builder
I0924 22:00:36.384] multiarch-multiplatform-builder
I0924 22:00:36.390] DOCKER_CLI_EXPERIMENTAL=enabled docker run --rm --privileged multiarch/qemu-user-static --reset --credential yes --persistent yes
W0924 22:00:36.491] Unable to find image 'multiarch/qemu-user-static:latest' locally
W0924 22:00:38.302] latest: Pulling from multiarch/qemu-user-static
W0924 22:00:38.303] 24fb2886d6f6: Pulling fs layer
... skipping 208 lines ...
W0924 22:01:56.406] #13 0.518 Get:4 http://deb.debian.org/debian buster/main amd64 Packages [7907 kB]
W0924 22:01:56.707] #13 0.696 Get:5 http://deb.debian.org/debian buster-updates/main amd64 Packages [15.2 kB]
W0924 22:02:07.225] #13 ...
W0924 22:02:07.225] 
W0924 22:02:07.225] #14 [mad-hack 2/2] RUN clean-install udev
W0924 22:02:07.225] #14 60.41 Err:2 http://deb.debian.org/debian buster InRelease
W0924 22:02:07.226] #14 60.41   Connection failed [IP: 199.232.98.132 80]
W0924 22:02:07.226] #14 60.43 Get:1 http://security.debian.org/debian-security buster/updates InRelease [65.4 kB]
W0924 22:02:07.226] #14 60.50 Get:3 http://deb.debian.org/debian buster-updates InRelease [51.9 kB]
W0924 22:02:07.526] #14 60.66 Get:4 http://security.debian.org/debian-security buster/updates/main amd64 Packages [305 kB]
W0924 22:02:07.631] #14 60.84 Get:5 http://deb.debian.org/debian buster-updates/main amd64 Packages [15.2 kB]
W0924 22:02:07.632] #14 60.85 Fetched 437 kB in 1min 1s (7218 B/s)
W0924 22:02:07.633] #14 60.85 Reading package lists...
W0924 22:02:07.732] #14 60.91 W: Failed to fetch http://deb.debian.org/debian/dists/buster/InRelease  Connection failed [IP: 199.232.98.132 80]
W0924 22:02:07.733] #14 60.91 W: Some index files failed to download. They have been ignored, or old ones used instead.
W0924 22:02:07.733] #14 60.93 Reading package lists...
W0924 22:02:07.733] #14 61.00 Building dependency tree...
W0924 22:02:07.883] #14 61.00 Reading state information...
W0924 22:02:07.884] #14 61.01 Some packages could not be installed. This may mean that you have
W0924 22:02:07.884] #14 61.01 requested an impossible situation or if you are using the unstable
W0924 22:02:07.884] #14 61.01 distribution that some required packages have not yet been created
... skipping 3 lines ...
W0924 22:02:07.884] #14 61.01 The following packages have unmet dependencies:
W0924 22:02:07.884] #14 61.01  udev : Depends: libblkid1 (>= 2.24) but it is not installable
W0924 22:02:07.885] #14 61.01         Depends: libkmod2 (>= 5~) but it is not installable
W0924 22:02:07.885] #14 61.01         Depends: lsb-base (>= 3.0-6) but it is not installable
W0924 22:02:07.885] #14 61.01         Depends: util-linux (>= 2.27.1) but it is not installable
W0924 22:02:07.885] #14 61.01 E: Unable to correct problems, you have held broken packages.
W0924 22:02:07.885] #14 ERROR: process "/bin/sh -c clean-install udev" did not complete successfully: exit code: 100
W0924 22:02:07.885] 
W0924 22:02:07.885] #13 [stage-2 3/4] RUN clean-install util-linux e2fsprogs mount ca-certificates udev xfsprogs
W0924 22:02:07.900] #13 CANCELED
W0924 22:02:07.901] ------
W0924 22:02:07.901]  > [mad-hack 2/2] RUN clean-install udev:
W0924 22:02:07.901] #14 61.01 distribution that some required packages have not yet been created
... skipping 12 lines ...
W0924 22:02:07.906]   26 |     # MAD HACKS: Build a version first so we can take the scsi_id bin and put it somewhere else in our real build
W0924 22:02:07.906]   27 |     FROM k8s.gcr.io/build-image/debian-base:buster-v1.9.0 as mad-hack
W0924 22:02:07.906]   28 | >>> RUN clean-install udev
W0924 22:02:07.906]   29 |     
W0924 22:02:07.907]   30 |     # Start from Kubernetes Debian base
W0924 22:02:07.907] --------------------
W0924 22:02:07.907] error: failed to solve: process "/bin/sh -c clean-install udev" did not complete successfully: exit code: 100
W0924 22:02:07.919] make: *** [Makefile:50: build-container] Error 1
I0924 22:02:08.020] make: Leaving directory '/go/src/sigs.k8s.io/gcp-compute-persistent-disk-csi-driver'
W0924 22:02:09.212] F0924 22:02:09.212059    3631 main.go:189] Failed to run integration test: failed pushing image: failed to run make command for linux: err: exit status 2
W0924 22:02:09.216] Traceback (most recent call last):
W0924 22:02:09.216]   File "/workspace/./test-infra/jenkins/../scenarios/execute.py", line 50, in <module>
W0924 22:02:09.217]     main(ARGS.env, ARGS.cmd + ARGS.args)
W0924 22:02:09.217]   File "/workspace/./test-infra/jenkins/../scenarios/execute.py", line 41, in main
W0924 22:02:09.217]     check(*cmd)
W0924 22:02:09.217]   File "/workspace/./test-infra/jenkins/../scenarios/execute.py", line 30, in check
W0924 22:02:09.217]     subprocess.check_call(cmd)
W0924 22:02:09.217]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0924 22:02:09.217]     raise CalledProcessError(retcode, cmd)
W0924 22:02:09.218] subprocess.CalledProcessError: Command '('test/run-k8s-integration-migration.sh',)' returned non-zero exit status 255
E0924 22:02:09.226] Command failed
I0924 22:02:09.226] process 432 exited with code 1 after 3.3m
E0924 22:02:09.226] FAIL: ci-gcp-compute-persistent-disk-csi-driver-latest-k8s-master-migration
I0924 22:02:09.227] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0924 22:02:10.095] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0924 22:02:10.282] process 6558 exited with code 0 after 0.0m
I0924 22:02:10.283] Call:  gcloud config get-value account
I0924 22:02:11.219] process 6571 exited with code 0 after 0.0m
I0924 22:02:11.219] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
... skipping 20 lines ...