This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 7 succeeded
Started2020-02-23 06:57
Elapsed5m6s
Revision
Builderb7486bde-5609-11ea-b3e8-d6ec3858e36a
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/8fdb8aaf-e76f-426c-b6d9-0a60912ce4b3/targets/test'}}
resultstorehttps://source.cloud.google.com/results/invocations/8fdb8aaf-e76f-426c-b6d9-0a60912ce4b3/targets/test
infra-commita7e5c6d26
job-versionv1.19.0-alpha.0.169+31b8c0d23d7aed
repok8s.io/kubernetes
repo-commit31b8c0d23d7aed208156be0e872bdc0bc2ea4414
repos{u'k8s.io/kubernetes': u'master', u'github.com/google/cadvisor': u'master'}
revisionv1.19.0-alpha.0.169+31b8c0d23d7aed

Test Failures


Node Tests 3m38s

error during go run /go/src/k8s.io/kubernetes/test/e2e_node/runner/remote/run_remote.go --cleanup --logtostderr --vmodule=*=4 --ssh-env=gce --results-dir=/workspace/_artifacts --project=ci-cadvisor-e2e --zone=us-central1-f --ssh-user=prow --ssh-key=/workspace/.ssh/google_compute_engine --ginkgo-flags=--nodes=1 --test_args= --test-timeout=10m0s --image-config-file=/workspace/test-infra/jobs/e2e_node/image-config.yaml --test-suite=cadvisor: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 7 Passed Tests

Error lines from build-log.txt

... skipping 391 lines ...
I0223 07:00:38.477] >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
I0223 07:00:38.478] >                              START TEST                                >
I0223 07:00:38.478] >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
I0223 07:00:38.478] Start Test Suite on Host 
I0223 07:00:38.478] 
I0223 07:00:38.478] Failure Finished Test Suite on Host 
I0223 07:00:38.478] unable to create test archive: failed to setup test package "/tmp/node-e2e-archive983171877": failed to run command /go/src/github.com/google/cadvisor/build/prow_e2e.sh. error: exit status 1
I0223 07:00:38.478] <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
I0223 07:00:38.479] <                              FINISH TEST                               <
I0223 07:00:38.479] <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
I0223 07:00:38.479] 
W0223 07:02:35.906] I0223 07:02:35.906023    4519 run_remote.go:772] Deleting instance "tmp-node-e2e-73e0e7be-cos-stable-60-9592-84-0"
I0223 07:02:36.739] 
I0223 07:02:36.739] >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
I0223 07:02:36.739] >                              START TEST                                >
I0223 07:02:36.739] >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
I0223 07:02:36.740] Start Test Suite on Host 
I0223 07:02:36.740] 
I0223 07:02:36.740] Failure Finished Test Suite on Host 
I0223 07:02:36.740] unable to create test archive: failed to setup test package "/tmp/node-e2e-archive983171877": failed to run command /go/src/github.com/google/cadvisor/build/prow_e2e.sh. error: exit status 1
I0223 07:02:36.740] <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
I0223 07:02:36.740] <                              FINISH TEST                               <
I0223 07:02:36.741] <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
I0223 07:02:36.741] 
W0223 07:02:39.090] I0223 07:02:39.089842    4519 run_remote.go:772] Deleting instance "tmp-node-e2e-73e0e7be-cos-stable-63-10032-71-0"
I0223 07:02:39.590] 
I0223 07:02:39.591] >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
I0223 07:02:39.591] >                              START TEST                                >
I0223 07:02:39.591] >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
I0223 07:02:39.591] Start Test Suite on Host 
I0223 07:02:39.591] 
I0223 07:02:39.591] Failure Finished Test Suite on Host 
I0223 07:02:39.592] unable to create test archive: failed to setup test package "/tmp/node-e2e-archive983171877": failed to run command /go/src/github.com/google/cadvisor/build/prow_e2e.sh. error: exit status 1
I0223 07:02:39.592] <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
I0223 07:02:39.592] <                              FINISH TEST                               <
I0223 07:02:39.592] <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
I0223 07:02:39.592] 
I0223 07:02:39.592] Failure: 3 errors encountered.
W0223 07:02:39.693] exit status 1
W0223 07:02:39.895] 2020/02/23 07:02:39 process.go:155: Step 'go run /go/src/k8s.io/kubernetes/test/e2e_node/runner/remote/run_remote.go --cleanup --logtostderr --vmodule=*=4 --ssh-env=gce --results-dir=/workspace/_artifacts --project=ci-cadvisor-e2e --zone=us-central1-f --ssh-user=prow --ssh-key=/workspace/.ssh/google_compute_engine --ginkgo-flags=--nodes=1 --test_args= --test-timeout=10m0s --image-config-file=/workspace/test-infra/jobs/e2e_node/image-config.yaml --test-suite=cadvisor' finished in 3m38.853517769s
W0223 07:02:39.896] 2020/02/23 07:02:39 node.go:42: Noop - Node DumpClusterLogs() - /workspace/_artifacts: 
W0223 07:02:39.896] 2020/02/23 07:02:39 node.go:52: Noop - Node Down()
W0223 07:02:39.896] 2020/02/23 07:02:39 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0223 07:02:39.896] 2020/02/23 07:02:39 process.go:153: Running: bash -c . hack/lib/version.sh && KUBE_ROOT=. kube::version::get_version_vars && echo "${KUBE_GIT_VERSION-}"
W0223 07:02:40.205] 2020/02/23 07:02:40 process.go:155: Step 'bash -c . hack/lib/version.sh && KUBE_ROOT=. kube::version::get_version_vars && echo "${KUBE_GIT_VERSION-}"' finished in 309.111452ms
W0223 07:02:40.205] 2020/02/23 07:02:40 main.go:316: Something went wrong: encountered 1 errors: [error during go run /go/src/k8s.io/kubernetes/test/e2e_node/runner/remote/run_remote.go --cleanup --logtostderr --vmodule=*=4 --ssh-env=gce --results-dir=/workspace/_artifacts --project=ci-cadvisor-e2e --zone=us-central1-f --ssh-user=prow --ssh-key=/workspace/.ssh/google_compute_engine --ginkgo-flags=--nodes=1 --test_args= --test-timeout=10m0s --image-config-file=/workspace/test-infra/jobs/e2e_node/image-config.yaml --test-suite=cadvisor: exit status 1]
W0223 07:02:40.209] Traceback (most recent call last):
W0223 07:02:40.209]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0223 07:02:40.209]     main(parse_args())
W0223 07:02:40.210]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0223 07:02:40.210]     mode.start(runner_args)
W0223 07:02:40.210]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0223 07:02:40.210]     check_env(env, self.command, *args)
W0223 07:02:40.210]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0223 07:02:40.210]     subprocess.check_call(cmd, env=env)
W0223 07:02:40.210]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0223 07:02:40.210]     raise CalledProcessError(retcode, cmd)
W0223 07:02:40.211] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=node', '--provider=gce', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--gcp-project=ci-cadvisor-e2e', '--gcp-zone=us-central1-f', '--node-args=--image-config-file=/workspace/test-infra/jobs/e2e_node/image-config.yaml --test-suite=cadvisor', '--node-tests=true', '--test_args=--nodes=1', '--timeout=10m')' returned non-zero exit status 1
E0223 07:02:40.220] Command failed
I0223 07:02:40.221] process 333 exited with code 1 after 3.7m
E0223 07:02:40.221] FAIL: ci-cadvisor-e2e
I0223 07:02:40.221] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0223 07:02:40.760] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0223 07:02:40.819] process 4751 exited with code 0 after 0.0m
I0223 07:02:40.819] Call:  gcloud config get-value account
I0223 07:02:41.241] process 4764 exited with code 0 after 0.0m
I0223 07:02:41.242] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0223 07:02:41.242] Upload result and artifacts...
I0223 07:02:41.242] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-cadvisor-e2e/1231473129742667776
I0223 07:02:41.242] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-cadvisor-e2e/1231473129742667776/artifacts
W0223 07:02:42.394] CommandException: One or more URLs matched no objects.
E0223 07:02:42.532] Command failed
I0223 07:02:42.533] process 4777 exited with code 1 after 0.0m
W0223 07:02:42.533] Remote dir gs://kubernetes-jenkins/logs/ci-cadvisor-e2e/1231473129742667776/artifacts not exist yet
I0223 07:02:42.533] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-cadvisor-e2e/1231473129742667776/artifacts
I0223 07:02:44.657] process 4922 exited with code 0 after 0.0m
I0223 07:02:44.658] Call:  git rev-parse HEAD
I0223 07:02:44.662] process 5458 exited with code 0 after 0.0m
... skipping 13 lines ...